Si vous intervertissez deux lames dans deux chassis HP différents, il se peut que les lames conservent leur ancienne configuration.
Vous avez peut-être essayer de reconfigurer l'EBIPA depuis l'Onboard Administrator du chassis, mais cela ne semble pas fonctionner...

La console d'administration de la lame ne peut donc pas être utilisée et cela est très contraignant...


La solution consiste à reconfigurer l'iLO en ligne de commande :

1. Se connecter en ssh à l'OA du chassis (ici c'est un C7000)

ssh administrator@BC36mngt1.simonek.fr
-----------------------------------------------------------------------------
WARNING: This is a private system.  Do not attempt to login unless you are an
authorized user.  Any authorized or unauthorized access and use may be moni-
tored and can result in criminal or civil prosecution under applicable law.
-----------------------------------------------------------------------------
Firmware Version: 3.55
Built: 03/20/2012 @ 11:00
OA Bay Number:  1
OA Role:        Active
administrator@BC36mngt1.simonek.fr's password:


HP BladeSystem Onboard Administrator
(C) Copyright 2006-2012 Hewlett-Packard Development Company, L.P.


Type 'HELP' to display a list of valid commands.
Type 'HELP <command>' to display detailed information about a specific command.
Type 'HELP HELP' to display more detailed information about the help system.

2. Se connecter à la lame (ici emplacement 8 du chassis)

bc36mngt1> connect server 8

Connecting to bay 8 ...
User:OAtmp-administrator-5203585A logged-in to bc25r2c36ilo6.simonek.fr(10.81.0.160)
iLO 2 Standard Blade Edition 1.80 at 10:12:14 Oct 30 2009
Server Name: host is unamed
Server Power: On

</>hpiLO->

3. On affiche les valeurs actuelles :

</>hpiLO-> show /map1/enetport1/lanendpt1/ipendpt1
status=0
status_tag=COMMAND COMPLETED

/map1/enetport1/lanendpt1/ipendpt1
  Targets
  Properties
    IPv4Address=10.81.0.160
    SubnetMask=255.255.255.0
    AddressOrigin=Static
  Verbs
    cd version exit show set

</>hpiLO->show gateway1
status=0
status_tag=COMMAND COMPLETED

/map1/gateway1
  Targets
  Properties
    AccessInfo=10.150.240.1
    AccessContext=Default Gateway
  Verbs
    cd version exit show set

4. On modifie ces valeurs (à faire ne deux temps car chaque modification entraine un reset de l'iLO)

L'adresse IP :

</>hpiLO->set /map1/enetport1/lanendpt1/ipendpt1 IPv4Address=10.13.247.222 SubnetMask=255.255.240.0
status=0
status_tag=COMMAND COMPLETED
Network settings change applied, iLO needs to be reset.

CLI session stopped

Connection terminated by server.

La passerelle :

</>hpiLO->set /map1/gateway1 AccessInfo=10.13.240.1
status=0
status_tag=COMMAND COMPLETED
Network settings change applied, iLO needs to be reset.

CLI session stopped

Et Voilà :)

J'avais également écrit un article sur une autre méthode mais cela ne semble plus fonctionner avec les nouvelles versions d'iLO :

http://www.simonek.fr/post/2010/11/15/Divers-Configurer-l-adresse-IP-d-un-HP-iLO-en-ligne-de-commande